AP Bug to fix list

  • MetAssassina
  • Topic Author
  • Offline
  • Premium Member
  • Premium Member
More
2 years 8 months ago - 2 years 7 months ago #4115 by MetAssassina
AP Bug to fix list was created by MetAssassina
Our Beloved DEV need a list of he bug you meet or know ingame,

ad your bug, i'll update the list in this first post to make easier to check if a bug is already in list...

Thanks a lot

BUG LIST :

1-fold space seems to show a red line same as a moving BG, when fold space ship arrived long ago.

2-When opening Command manager, units are not listed in alphabetical, making unit localisation uneasy (edit : looks like already fixed?)

3-when repairing units in SS or ground fac, when selecting repair all > numbers of armour or struct to replace may change if stop/restart, some number are wrong and (way) too high. when selecting unit one by one, things are better but still not accurate

4-some specific colonies refuses to queue items in colonial management, while others do


5-Sometimes Pirates units fly towards 0,0 (the star of a system) when trying to land on planets. This is probably related to the well-known bug that affects players in the same way (player units trying to land on planets fly towards 0,0...this sometimes also affects units moving in formation planetside...if planetside it's the center of the planet map)

6-This one has not yet been observed recently. Pirates sometimes did not despawn everywhere when the despawn signal is given...they would remain in space or planetside and need to be cleared by players who could. I know this can be fun for some players, though it is a bug so I figured I'd mention it.

7-Another old one: when the Pirates were on a timed cycle, the timer would sometimes glitch out and an attack would never stop, would go on for hours/until Sir P would come online and turn them off, maybe reboot the server.

8-Player flags are not showing in the Diplomacy window to some players.

9-Never ending and hyper expensive fac reparing loop bug...you launch a repair forget it and discover day later it burned your credits.


to be continued...
Last edit: 2 years 7 months ago by MetAssassina.

Please Log in to join the conversation.

More
2 years 8 months ago #4116 by tesboom
Replied by tesboom on topic Re: AP Bug to fix list
some specific colonies refuses to queue items in colonial managment, while others do

Please Log in to join the conversation.

More
2 years 8 months ago - 2 years 8 months ago #4120 by Amerlain
Replied by Amerlain on topic Re: AP Bug to fix list
Just a few more, mostly to do with Pirates this time.

1) Sometimes Pirates units fly towards 0,0 (the star of a system) when trying to land on planets. This is probably related to the well-known bug that affects players in the same way (player units trying to land on planets fly towards 0,0...this sometimes also affects units moving in formation planetside...if planetside it's the center of the planet map). This was seen recently (only two units, but proves it happens).

2) This one has not yet been observed recently (since the server was installed in Sir P's new datacenter). Pirates sometimes did not despawn everywhere when the despawn signal is given...they would remain in space or planetside and need to be cleared by players who could. I know this can be fun for some players, though it is a bug so I figured I'd mention it.

3) Another old one: when the Pirates were on a timed cycle, the timer would sometimes glitch out and an attack would never stop, would go on for hours/until Sir P would come online and turn them off, maybe reboot the server. I don't remember all the particulars of this one, I just remember it happening, along with very bad lag at the same time. So far hasn't happened since the relocation of the server, which I'm happy about, so possibly fixed.

Well, that's all I have for now. When I see (or remember) more, I'll post them.
Last edit: 2 years 8 months ago by Amerlain.

Please Log in to join the conversation.

More
2 years 8 months ago #4124 by Alien-Breed
Replied by Alien-Breed on topic Re: AP Bug to fix list
old bug still happens .
In the design console when you dont have "best match" box checked for sorting your list of ore/mineral the scroll function wont keep its place so when you try to scroll down the list after a second the scroll bar jumps back to the top before you can click on a mineral or ore .

Please Log in to join the conversation.

More
2 years 8 months ago #4125 by Amerlain
Replied by Amerlain on topic Re: AP Bug to fix list
This is a small one. Player flags are not showing in the Diplomacy window. I've noticed this has been the case since the server's return.

Please Log in to join the conversation.

More
2 years 8 months ago #4126 by Alien-Breed
Replied by Alien-Breed on topic Re: AP Bug to fix list
i did see the flags , i was looking at diplomacy last night, so could be your end?

Please Log in to join the conversation.

Time to create page: 0.268 seconds